Wednesday, April 14, 2010
Tuesday, April 13, 2010
Barge and cBarge on CUCM
To add Barge or cBarge :
- Barge:
- Device / Phone : turn Privacy to OFF (default is ON)
- Device / Phone : set Built In Bridge to ON
- Device / Phone : select Single Button Barge to either Barge or cBarge (default is OFF)
- Device / Phone : select a Softkey Template. For Barge, a Standard User template is sufficient
- Device / Phone : add a shared-line DN, i.e 2001 for both test phones
- cBarge:
- Device / Phone : turn Privacy to OFF (default is ON)
- Device / Phone : set Built In Bridge to ON
- Device / Phone : select Single Button Barge to either Barge or cBarge (default is OFF)
- Device / Phone : select a Softkey Template. For cBarge, copy Standard User template to a new template and add cBarge softkey in call state "Remote In Use"
- Device / Phone : add a shared-line DN, i.e 2001 for both test phones
Thursday, April 8, 2010
Tasks notes - important, go over
- CUE and CME:
- add voice translation-rule/profile for VM numbers
- enable SIP - H323 interwork via "voice service voip"
- bind SIP to interface gig0/0.230 (or same interface with CME)
- enable SIP-UA
- add Dial-Peer to make sure calls will reach CUE with SIP protocol and G711u - don't forget to include voice translation-profile
- add Dial-Peer to make sure MWI numbers will use G711u
- add num-exp (i.e num-exp 3500 21313500) to enable calls from PSTN to reach VM
- add voicemail number in CME and call-forward in ephone-dn
- add MWI on/off ephone-dn
- add Transcoder into CME if VM access from other sites (HQ or BR1) is needed
- use CUE Wizard for rest of task
Wednesday, April 7, 2010
AAR simplified in 5 minutes
In brief, AAR is for Automated Alternate Routing in case the WAN/IP network routing or bandwidth is restrictive to pass voice calls. Don't confuse this with SRST which is another subject
Procedure to setup AAR:
Procedure to setup AAR:
- Decrease the bandwidth between sites so that a voice call wont have enough bandwidth, i.e change location bandwidth to 20K (minimum is 24K for g728 and 80K for g711).
- on CUCM, Call-Routing / AAR-Group, add AAR-HQ, AAR-BR1 ...
- Depend on the DialPlan configured previously, there 're 2 scenarios here for AAR routing.
- If you configured global Route-Pattern \+! then adding Translation-Pattern to route calls , there 're no need to add Dial_prefix between sites since the global RP \+! should match all routes.
- If you configured multiple RP for local/LD/INTL numbers, then calls using PSTN from HQ to BR1 should include prefix 9 (if BR1 External Phone Number Mask is 11 digits , i.e 1312301XXXX) or prefix 91 (if BR1 External Phone Number Mask is 10 digits , i.e 312301XXXX) and local calls inside HQ should use prefix 9 .
- Update both HQ and BR1 Device/Phone AAR-CSS and AAR-Group with appropriate info.
- Update both HQ and BR1 Device/Phone/Line AAR Settings with appropriate AAR Group.
- Update both HQ and BR1 Gateway AAR-CSS and AAR-Group with appropriate info.
Wednesday, March 24, 2010
IPIPGW from CUCM to BR2
Tasks: configure HQ gw as IPIPGW aka CUBE to handle SIP calls from CUCM to BR2 CME
Recall that CUCM is using a SIP-TRUNK and codec g711u while CME on the BR2 side is using H.323 and codec g729r8.
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
sip
bind control source-interface Loopback0
bind media source-interface Loopback0
interface Loopback0
ip address 10.10.32.1 255.255.255.255
ip ospf network point-to-point
h323-gateway voip interface
h323-gateway voip h323-id HQ-IPIPGW
h323-gateway voip bind srcaddr 10.10.32.1
gateway
sip-ua
no dspfarm
dsp services dspfarm
sccp local GigabitEthernet0/0.30
sccp ccm 10.10.30.1
sccp ip precedence 3
sccp
sccp ccm group 1
associate ccm 1 priority 1
associate profile 1 register HQ-XCODER
!
dspfarm profile 1 transcode
maximum sessions 2
associate application SCCP
telephony-service
sdspfarm units 1
sdspfarm transcode sessions 2
sdspfarm tag 1 HQ-XCODER
max-ephones 2
max-dn 4
ip source-address 10.10.30.1 port 2000
create cnf-files
description ==== IPIPGW h323 to BR2 area code
destination-pattern 4423.T
session target ipv4:10.10.32.3
dtmf-relay h245-alphanumeric
no vad
codec g729r8
dial-peer voice 1001 voip
description ==== abbrev. dialing to BR2 internal IP phones
destination-pattern 3...$
session target ipv4:10.10.32.3
dtmf-relay h245-alphanumeric
no vad
ip address 10.10.32.3 255.255.255.255
ip ospf network point-to-point
h323-gateway voip interface
h323-gateway voip h323-id BR2
h323-gateway voip bind srcaddr 10.10.32.3
gateway
rule 2 /^44232131\(3\)\(...\)$/ /\1\2/ ==== strip to 3xxx for BR2 IP phones
rule 3 /^4423\(........\)$/ /9\1/ ==== strip to 9xxxxxxxx for BR2 local calls
voice translation-profile teho-cucm-to-br2
translate called 1
dial-peer voice 2000 voip
description ==== incoming from CUCM
translation-profile incoming teho-cucm-to-br2
incoming called-number 4423.T
dtmf-relay h245-alphanumeric
no vad
codec g729r8
rule 1 /1\(...\)$/ /7752011\1/
rule 2 /1\(...\)$/ /3123012\1/
voice translation-pro to-cucm
translate called 2
dial-peer voice 2001 voip
description ==== from BR2 to CUCM
translation-profile outgoing to-cucm
preference 1
destination-pattern [1-2]...$
session target ipv4:10.10.32.1 ==== this is HQ Loop 0 int
dtmf-relay h245-alphanumeric
codec g729r8
no vad
description ==== BR2 calls to CUCM
preference 1
destination-pattern 775.T
session protocol sipv2
session target ipv4:10.1.200.21 ==== this is CUCM IP addrs
dtmf-relay rtp-nte
codec g711ulaw
set SIP-TRUNK-IPIPGW with CSS-IPIPGW , significant-digits = ALL
add translation-pattern , pattern = 775201.XXXX , PT = PT-IPIPGW , CSS = CSS-IPIPGW
Additional tasks for BR2 to call HQ area code numbers
translation-profile outgoing teho-to-cucm
destination-pattern 9001312.T
session target ipv4:10.10.32.1
codec g729r8
dtmf-relay h245-alphanumeric
no vad
description ==== handle calls from BR2 , teho to BR1 area
destination-pattern 312.T
session protocol sipv2
session target ipv4:10.1.200.21
codec g729r8
dtmf-relay h245-alphanumeric
Recall that CUCM is using a SIP-TRUNK and codec g711u while CME on the BR2 side is using H.323 and codec g729r8.
- config HQ gw as IPIPGW with SIP interfacing CUCM and H323 toward BR2 CME
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
sip
bind control source-interface Loopback0
bind media source-interface Loopback0
interface Loopback0
ip address 10.10.32.1 255.255.255.255
ip ospf network point-to-point
h323-gateway voip interface
h323-gateway voip h323-id HQ-IPIPGW
h323-gateway voip bind srcaddr 10.10.32.1
gateway
sip-ua
- config HQ gw with DSP resource to do transcoding. NOTE: IPIPGW binds to Loopback0 while DSP resources bind to Gig0/0.30. Test by calling from HQ toward BR2 PSTN and place both phones off-hook. If TRANSCODING is not working , will get busy tone when going off-hook.
no dspfarm
dsp services dspfarm
sccp local GigabitEthernet0/0.30
sccp ccm 10.10.30.1
sccp ip precedence 3
sccp
sccp ccm group 1
associate ccm 1 priority 1
associate profile 1 register HQ-XCODER
!
dspfarm profile 1 transcode
maximum sessions 2
associate application SCCP
telephony-service
sdspfarm units 1
sdspfarm transcode sessions 2
sdspfarm tag 1 HQ-XCODER
max-ephones 2
max-dn 4
ip source-address 10.10.30.1 port 2000
create cnf-files
- config HW gw with a dial-peer to point H323 dialed string to BR2
description ==== IPIPGW h323 to BR2 area code
destination-pattern 4423.T
session target ipv4:10.10.32.3
dtmf-relay h245-alphanumeric
no vad
codec g729r8
dial-peer voice 1001 voip
description ==== abbrev. dialing to BR2 internal IP phones
destination-pattern 3...$
session target ipv4:10.10.32.3
dtmf-relay h245-alphanumeric
no vad
- Add a SIP-TRUNK on CUCM, this is SIP trunk from CUCM to HQ gw. Device-name = SIP-TRUNK-IPIPGW , DP = HQ , location = HQ , SIP destination-address = HQ Loopback0
- Add this SIP-TRUNK into RG-BR2 .
- Add RL-TEHO-HQ-TO-BR2 with 1st RG = RG-BR2 (Use Calling Party's External Phone Number Mask = ON , Discard Digits = predot) , 2nd RG = RG-HQ (Use Calling Party's External Phone Number Mask = ON , Discard Digits = predot , Prefix Digits (Outgoing Calls) = 011 ) .
- Add Route-Pattern 9011.4423XXXXXXXX , partition = PT-HQ-INTL , Route-List = RL-TEHO-HQ-TO-BR2 , urgent priority , strip PREDOT .
- For abbrev. dialing to BR2 internal IP phones , add following : RL = RL-TEHO-HQ-TO-BR2-INTERNAL with 1st RG = RG-BR2 (Use Calling Party's External Phone Number Mask = ON , Discard Digits = predot) , 2nd RG = RG-HQ (Use Calling Party's External Phone Number Mask = ON , Discard Digits = predot , Prefix Digits (Outgoing Calls) = 01144232131 ) . Pretty much same RL as on step 3 , except for the PSTN dialing part . Add Router-Pattern 3XXX , PT = PT-internal , RL = RL-TEHO-HQ-TO-BR2-INTERNAL
- config BR2 as H323 GW
ip address 10.10.32.3 255.255.255.255
ip ospf network point-to-point
h323-gateway voip interface
h323-gateway voip h323-id BR2
h323-gateway voip bind srcaddr 10.10.32.3
gateway
- config voice translation-rule & dial-peer to handle incoming calls from VOIP
rule 2 /^44232131\(3\)\(...\)$/ /\1\2/ ==== strip to 3xxx for BR2 IP phones
rule 3 /^4423\(........\)$/ /9\1/ ==== strip to 9xxxxxxxx for BR2 local calls
voice translation-profile teho-cucm-to-br2
translate called 1
dial-peer voice 2000 voip
description ==== incoming from CUCM
translation-profile incoming teho-cucm-to-br2
incoming called-number 4423.T
dtmf-relay h245-alphanumeric
no vad
codec g729r8
Test calls by calling from HQ phones to BR2 internal phones + BR2 area PSTN numbers
- config voice translation-rule and dial-peer in BR2 for abbrev. dialing to CUCM
rule 1 /1\(...\)$/ /7752011\1/
rule 2 /1\(...\)$/ /3123012\1/
voice translation-pro to-cucm
translate called 2
dial-peer voice 2001 voip
description ==== from BR2 to CUCM
translation-profile outgoing to-cucm
preference 1
destination-pattern [1-2]...$
session target ipv4:10.10.32.1 ==== this is HQ Loop 0 int
dtmf-relay h245-alphanumeric
codec g729r8
no vad
- config IPIPGW dial-peer to handle incoming calls from BR2
description ==== BR2 calls to CUCM
preference 1
destination-pattern 775.T
session protocol sipv2
session target ipv4:10.1.200.21 ==== this is CUCM IP addrs
dtmf-relay rtp-nte
codec g711ulaw
- config CUCM to handle incoming calls from BR2
set SIP-TRUNK-IPIPGW with CSS-IPIPGW , significant-digits = ALL
add translation-pattern , pattern = 775201.XXXX , PT = PT-IPIPGW , CSS = CSS-IPIPGW
Additional tasks for BR2 to call HQ area code numbers
- dial-peer voice 2002 voip ==== dial-peer on BR2
description ==== from BR2 to CUCM area code
preference 1
destination-pattern 9001775.......$
session target ipv4:10.10.32.1
dtmf-relay h245-alphanumeric
codec g729r8
- voice translation-rule 1 ==== add voice translation-rule on HQ GW
rule 3 /9001\(.*\)/ /\1/
voice translation-profile DID
translate called 1
dial-peer voice 1002 voip ==== same dial-peer configured before on HQ
translation-profile incoming DID
incoming called-number . - on CUCM , add other PT such as PT-HQ-LOCAL , PT-HQ-LD into CSS-IPIPGW .
- Add Translation-pattern , pattern = 775.XXXXXXX , PT = PT-IPIPGW , CSS = CSS-IPIPGW , discard-digit = PREDOT , Prefix Digits (Outgoing Calls) = 9 (remember , we want to use the HQ GW for PSTN local calls).
CAVEATS: TEHO calls from BR2 to BR1 area configs:
- on BR2, add voip dial-peer
translation-profile outgoing teho-to-cucm
destination-pattern 9001312.T
session target ipv4:10.10.32.1
codec g729r8
dtmf-relay h245-alphanumeric
no vad
- on HQ gw, add voip dial-peer to forward incoming calls from BR2 to CUCM, but specify g729codec
description ==== handle calls from BR2 , teho to BR1 area
destination-pattern 312.T
session protocol sipv2
session target ipv4:10.1.200.21
codec g729r8
dtmf-relay h245-alphanumeric
- Test by calling from BR2 phones to BR1 area code number. Should see calls coming out of BR1 GW. Note: on CUCM, should set Region for G729 between HQ and BR1 (default is G711).
Tasks to go over before the LAB test - voice exam check list
- DialPlan with GK - posted
- DialPlan with IPIPGW - posted
- DialPlan with COR - done
- DialPlan with Local-route (single RP, translation-pattern, transformation-pattern)
- CME with SCCP - done
- CME with SIP endpoints - need to do SIP
- CUE with CME - posted
- CUE with CUCM - posted
- Extension mobillity - posted
- SNR - posted
- SRST
- AAR - posted
- Call park, Call pickup, Barge, Callback - done Barge/cBarge, CallBack, callPark, callPickup = not enough phone
- IPMA - posted
- QOS -
- IPCCEx scripting - need to do
- https://learningnetwork.cisco.com/docs/DOC-7024
Tuesday, March 16, 2010
Integrating CUE and CUCM
CUE config:
interface Service-Engine2/0ip unnumbered GigabitEthernet0/0.130
service-module ip address 10.10.130.3 255.255.255.0 >>> this is the IP addr of CUE
service-module ip default-gateway 10.10.130.1
ip route 10.10.130.3 255.255.255.255 Service-Engine2/0
>>> no other config on CUE or IOS router is necessary
Log into CUE module and restore to factory default
BR1#service-module in2/0 sess
....
NME-CUE#
NME-CUE# offline
....
Are you sure you want to go offline[n]? : y
....
NME-CUE(offline)# restore factory default
NME-CUE(offline)#
MONITOR SHUTDOWN...
After a few minutes, CUE will boot up, fill in the necessary info
Do you wish to start configuration now (y,n)? y
.................
Enter Call Agent
(CME, CCM, or enter to use CME as default): CCM >>>> make sure you select CCM
Selected Call Agent: CCM
Setting Call Agent to CCM in /usr/wfavvid/workflow.properties
....
....
Enter administrator user ID:
(user ID): admin
Enter password for admin:
(password):
Confirm password for admin by reentering it:
(password):
SYSTEM ONLINE
br1-cue# sh software license
....
Core:
- Application mode: CCM
- Total usable system ports: 8 >>>CUE has 8 lic ports, make sure on CUCM, you will add 8 CTI ports ..... hmmmm, maybe 2 CTI ports is good enough . Verified operation on 3/29 with 2 CTI ports.
....
br1-cue#
- Add CTI port on CUCM, under Device/Phone, add new Phone Type = CTI Port, device name = cue1, DP = BR1, location = BR1. Add new DN for the CTI Port, DN = 1601, PT = PT-USA . Repeat for all ports of CUE. Verified operation on 3/29 with 2 CTI ports.
- IMPORTANT : don't forget to config "External Phone Number Mask" for CUE CTI ports and Route-Point , or they won't register in CUCM
- Add CTI Route Point on CUCM, under Device/CTI Route Point, add new CTI RP, device name = BR1-CUE , DP = BR1, location = BR1 , CSS = CSS-GLOBAL. Add new DN for the CTI RP , DN = 1600, PT = PS-USA, CSS = CSS-GLOBAL.
- Add new application user, username = cue , password = cisco , Controlled Devices = cue1, cue1 .... cue8 , BR1-CUE , Groups/Roles = standard CTI enabled, CTI control of all devices, AXL API access. This username = CUE JTAPI username. Controlled Devices = BR1-CUE + cue1 + cue2 ...
- Create new Voicemail Pilot and Profile for CUE - on CUCM , create CUE Voicemail Pilot (DN=1600) and CUE Voicemail Profile . Assign this Voicemail Profile into IP phone (i.e. BR1 Phone1 , br1user1 ...) which wants to use CUE instead of Unity.
- Reload CUE. Re-login into CUE and verify imported users has "Primary Extension , i.e 2001, 1003
- Test by dialing into the IP phone (BR1 phone1) which was setup with the CUE Voicemail Profile above, should get the CUE prompt and MWI led should lit up. If a fast BUSY tone is heard when dialing CUE pilot # , there 're a mismatch of codec between sites (remember that CUE uses SIP and G711 only) . Either change codec relationship in System/Region or add in required Transcoder.
Screen shot of CTI Ports and CTI RP on a working CUCM. Notice that both CTI Ports & CTI RP are registered to CUCM with CUE IP addrs (10.10.130.3)
Subscribe to:
Posts (Atom)